[SOLVED] MySQL 5.6 memmory usage

edited June 2014 in Help
Hello everyone!
I have an issue with lots mem usage by MySQL. It's about 400Mb in idle here, but about 50Mb on another server (my old Laptop at home with Ubuntu desktop 14.04).
Is it some KVM virtualisation issue? Is there a way to fix this problem?
I have only 768Mb of RAM and 60% is taken by MySQL :(

htops:
1. vultr shard : http://enterprise-wow.tk/img/2014-06-17_1120.png
2. home server: http://enterprise-wow.tk/img/2014-06-17_1122.png

Comments

  • Sounds like your innodb buffer pool is set improperly, on startup innodb allocates itself into memory. This is typical of newer mysql installations.
    If you don't intend on using innodb heavily/at all, you should consider changing your buffer settings in /etc/mysql/my.cnf

    I also recommend using http://mysqltuner.pl to finetune your mysqld settings.
  • Thanx for an advice.
    MySQLTuner recomendation is only to enlarge query_cache_limit.

    innodb_buffer_pool is set to 128M.

    ------
    I've disabled InnoDB by adding:

    default-storage-engine=MyISAM
    default-tmp-storage-engine=MyISAM
    skip-innodb

    Log says that innodb is disabled and mysql is started normally

    but htop shows the same ~400M used by MySQL

  • edited June 2014
    I've found the solution!

    just added the following to my.cnf and mysql uses only ~70M instead of 400M
    table_open_cache = 300
    table_definition_cache = 300
    open_files_limit = 900

    I hope it'll help someone in future :)
  • MariaDB is performing a lot better than MySQL for me, maybe an option as well.
Sign In or Register to comment.