No internet access through OpenVPN server in Help

I spent the last few days trying to install and configure OpenVPN server on Vultr VPS on CentOS 6.9

I followed this guide:

https://www.quickservers.com/en/how-to-install-openvpn-on-centos.php

Long story short, everything seems to work fine, I am able to connect to the OpenVPN server using OpenVPN client on Windows computer as well as on my Android phone.

Only problem is I’m not able to access the internet through it. Am I doing something wrong or is Vultr blocking internet access through custom installed OpenVPN server?

Please note that I’m not talking about Vultr’s One-Click OpenVPN app.

Thanks.
Tagged:

Comments

  • Same problem here, could you find the reason?

    I deployed my own openvpn as, instead of using one-click app. I can connect through the client, I can check the status through ip address, but can't surf any website.
  • I haven't deployed openvpn, so can't help specifically. However, the only ports vultr blocks are port 25 (email)
  • I would suggest using an install script for openVPN(https://github.com/Nyr/openvpn-install). It's easier than editing all the settings yourself. When using the script make sure that you edit the firewall accordingly to the port you are using for OpenVPN.
  • edited July 23
    You need to enable IP forwarding for this to work.

    # Check to see if enabled (1 enabled 0 not enabled)
    sysctl net.ipv4.ip_forward

    # If not enabled
    sysctl -w net.ipv4.ip_forward=1

    # Restart networking
    service network restart

    # Test this and make sure its working, if it is make the change permanent:
    nano /etc/sysctl.conf
    # add or change the below if it exists
    net.ipv4.ip_forward = 1

    # run the below 2 commands
    sysctl -p /etc/sysctl.conf
    service network restart

    Should all work from here
Sign In or Register to comment.

Registration Required

A VULTR.com account is required to use the forum. Click here to sign in.

Quick Links