Everything is set correctly and still emails get rejected by mail.com

This is becoming very frustrating and the support team of mail.com has been everything but useful so trying my luck here.

Ok, so I've set up the mailserver on Plesk Onyx on a cloud here.

In the beginning nothing worked till I googled, asked some stuff on facebook and on mail-test I went from -0.3 to a 8.1 score and I pass authentication on all fronts.

When I send an email from roundcube to a gmail account all works fine, goes directly to the inbox, mails registered with Microsoft, some directly in the inbox and some in the spam folder, fine, I send an email to any address registered with mail.com it gets rejected instantly.

And when I try to send an email from the mail.com address to my plesk email it also gets rejected.

If I send an email with my Gmail to any mail.com address it works fine.

So what else can I do? I've configured everything I know correctly in Plesk, I added all the things needed to Vultr's DNS but I just can't get it to send to a mail.com address :(

Keep getting this error:

[code]
Reporting-MTA: dns; mail.mydomain.net
X-Postfix-Queue-ID: 63BA37450
X-Postfix-Sender: rfc822; support@mydomain.net
Arrival-Date: Mon, 11 Mar 2019 12:36:51 +0000 (UTC)

Final-Recipient: rfc822; myname@saintly.com
Original-Recipient: rfc822;myname@saintly.com
Action: failed
Status: 5.0.0
Remote-MTA: dns; mx00.mail.com
Diagnostic-Code: smtp; 550-Requested action not taken: mailbox unavailable 550
invalid DNS MX or A/AAAA resource record
[/code]

Cheers.

Comments

  • You would probably want an explict A record for mail.mydomain.net, rather then relying on your wildcard CNAME entry.

    Please note that wildcard CNAMEs are *not* a good idea. They have very tricky behavior, and are generally going to be a source of problems for you.
  • Thank you for your reply. I have solved it before I read this reply but you were right. I removed the Cname and gave the mail address an extra A record and works fine now.
  • Hi experts
    this thread is slightly old but if you are able to advise how you resolved the outgoing mail issue for gmail/outlook and other domains.
    I have configured SPF/DMARC/DKIM record. I have also configured type A record but I have not deleted the CNAME record; just as yet because I am not sure if I should do so. Deleting a DNS record sometimes takes the whole system down until the record is propogated and our site is LIVE.

    I logged a call with cpanel and their analysis is that there is a mismatch between the parent and local name server. See details in the below link

    https://discuss.vultr.com/discussion/1974/ptr-mismatch-reverse-dns-configured-but-not-resolving-to-an-ip#latest

    cpanel reckons it needs to be raised with "the server system". I have also read somewhere that the PTR record A does not get propogated until the upstream service provider creates it - not sure if that's true though. Because I don't see why the server system managers would create a system where they need to manually input PTR records for each individual customer. Sounds lame.

    If I have to believe cpanel that there is a mismatch in the NS configuration which they have derived after running the diagnosis using the command
    [dig selleasy.vultr.com +short a]

    I found the below wiki to configure the reseller's nameserver in cpanel to configure reseller choopa's local name server in WHM. I sent the link to cpanel to validate; if this was the correct spot to configure choopas local nameserve; but have not had any response
    https://documentation.cpanel.net/display/CKB/How+to+Set+Up+Nameservers+in+a+cPanel+Environment

    My Current server configuration is ns1 & ns2.vultr.com


    Qs: Are you able to confirm that I need to setup the local name servers for choopa as diagnosed and if so where?

    Qs: If you deleted the CNAME record to make the mail.com work; it makes me believe that gmail/outlook were working prior to the deletion. Hence does it make sense to delete the CNAME record or should I actually setup the choopa local namserver records?

    Qs: Do I have to contact the upstream server systems "vultr" / "choopa" to create the PTR record?

    Your help will be appreciated. Since our system is LIVE we need this resolved asap.

    Regards
    selleasy



Sign In or Register to comment.