No internet from Windows VPS with Vultr Firewall

Hello,

When adding a firewall to my Windows 10 VPS I lose internet connectivity (can't reach websites, services/apps don't work, etc.). When pinging sites their IPs are returned, but the ping fails. If removing the firewall it them works fine. I've tried the following:

  • Disabled entire Windows firewall.
  • No anti-virus, anti-malware, etc. software.
  • Restarted Windows multiple times
  • Added all port protocol types and ranges where applicable, to the firewall

Is there any outbound firewall settings I'm missing perhaps?

Thank you.

Comments

  • I was able to resolve this. I feel there's some issue with the 45.* subnet (in New Jersey if it's datacenter-specific) my original VPS was on. Another Windows VPS on the same subnet had the same issue, whereas a CentOS and third Windows VPS worked/work fine. I now have a firewall and rules active on this new VPS working as expected.

    I doubt any of these were the resolution, but if helpful for others, I performed these steps differently on this last Windows install:

    • Had a firewall with ICMP, all TCP and all UDP ports open, attached to the new VPS before mounting my Windows iso.
    • When installing the network adapter VirtIO driver in Windows, I pointed it to the driver in the NetKVM > w10 VirtIO driver folder in my custom iso (https://www.vultr.com/docs/windows-custom-iso-with-virtio-drivers) rather then the root of the VirtIO driver folder (maybe it previously used a different driver).
Sign In or Register to comment.