Plesk on Ubuntu 20.x LTS

Some else wish and updated Plesk application on Ubuntu 20.x LTS?

Vultr Plesk application still runs on Ubuntu 18.04 x64.

And Plesk supports Ubuntu 20.x LTS versions since Plesk Obsidian 18.0.29 which were released on 4 August 2020.

Comments

  • Hello,

    Thank you for your suggestion, we've passed it to our development team for consideration.

    --- David

  • Thank you in advance and this can be very helpful for VPS's which already run on Ubuntu 20.x LTS.

    In our case, we have different VPS's with Plesk and Ubuntu 20.x LTS and we can't migrate to Vultr which offers Plesk on Ubuntu 18.04 x64.

    I guess some other potentials new clients are in the same situation.

    Thank you again.-

Sign In or Register to comment.