Special characters console

edited July 2015 in Help
Hi, Im ubuntu console I need to do some special characters like @ and / but I cant.

How is the way?



  • @LaCueva
    I don't understand what you mean.
    What do you call "console", can you explain the circumstance where you can't use @ and /, and it might be helpful if you could tell us what you are trying to do.

    Using the Vultr WebVNC console to connect to a Debian server I can display both those characters. Using a SSH connection from my local Debian box in the KDE console (Konsole) I can do the same. e.g. echo @/;echo @/>test.txt;cat test.txt;touch @test.txt;ls @* @/ @/ @test.txt

    Vultr server and my local box:-
    echo $LANG en_AU.UTF-8 locale charmap UTF-8 locale -a C C.UTF-8 en_AU.utf8 POSIX

    See the above commands to determine what character settings and locale you use.

    locale -m will show all the available encodings

  • Im using vultr console and my keyboard is in spanish, I cant do any special character :(
  • @LaCueva

    That's a NoVNC web interface - it is using UTF-8.

    So the problem is your keyboard. As long as you are using the UTF-8 character set locally you can work around that.

    Type locale charmap into your local terminal to see if you are using the UTF-8 character set.
    If not, enable it (it supports the full Spanish character set including the accents and ¿ etc.).

    You'll also need to ensure your server has UTF-8 enabled. Please use it - it makes the internet easier if everyone can read everyone else's web-pages - that's what UTF-8 is for.

    There are several ways to insert special characters. If you choose the Alt+code method be sure and click on the Alt button in the Vultr console first. It'll change colour to show it's selected, click again to unselect it when you're done entering special characters.

    There's a guide here on how to insert special characters, in Spanish, and in English. Note: I have nothing to do with that site.

    I'd recommend switching to an SSH console whenever possible to make things simpler. I'm pretty sure Ubuntu has several utilities that make inserting special characters into a local console easier - if not you could try pulling them from Debian.

    Hope that helps
  • Same problem...
    I pressing the "View Console" on My Servers menu. And open my Ubuntu Server. On vultr console i cannot copy or paste and cannot press this special characters like @ and / . The locale charmap is UTF-8. Is there any way use for this special character?
  • @MeSuTh
    • What OS are you running on the box that you use to connect to Vult?
    • Did you try the method given at?
    • Is there a reason you can't use SSH to connect to your server?
    Is there any way use for this special character?
    Yes - the methods described in my previous post all work for me. It would be instructive if you could tell me which ones aren't working for you.
  • same problem, I created a new linux instance. Now I can't type password both of windows and mac machine using vultr console. I think you should set simple passwords first time or give a page for change password from website.
  • You can get ssh keys imported automatically when you build an instance.

    You can also use the auto-scripting to set the root password to what you desire.. That's what I do.. I hate those first time passwords too!
  • Hy, I have the same problem... I know, I need use ssh, I used, but lastday I reinstall my instance, and now I need manually set the ssh stuff... But I cant, because in the vultr console, no @ and no /, and I cant copy or paste (win10 op / debian 10 server, eng keyboard, eng win, etc...)... So now I think, I will destroy the current instance and I start a new... Anyway, It really doesnt care me this time, I reinstall a server, or I start a new, but the question is, what is the better for you?

  • NOTE: Remember when entering a password into the console you will not see anything and copy/paste will not work (without a work around that we wont get into).

  • edited October 2019

    Hi guys ,

    I ve one answer and one question for that .I am a MacOs User. Mojave.Locale Charmap UTF-8.

    I am using PuTTY as SSH . Go to system preferences/language&region and changeyour language settings to English(US) and make it primary. Restart the system. Now by pressing alt+Q you can have @ sign.

    Qustion is : how to copy a command line on the website and paste it to VULTR Console (or box or window . whatever you name it)

    Anybody can help ?

Sign In or Register to comment.