nginx and other questions in Help

edited September 2015 in Help
1) when deploying centOS, is it using the minimal ISO? i can only assume its a cut down version that might use less ram?

2) I have not found anywhere, but i can only assume the prices are in USD?, perhaps the currency should be listed.

3) when I deploy a CentOS6x64 LEMP server, it works no issue when i visit HTTP://SERVERIP/
however, deploying a fresh CentOSx64 server and manually installing NGINX gives me 504 Gateway Timeout.
these are the commands i run and it states NGINX is successfully running.
sudo yum install epel-release
sudo yum install nginx
sudo systemctl start nginx

I have also followed this article https://www.vultr.com/docs/how-to-speed-up-nginx-on-centos
and when i get to step 3, it gives me the following error
./config: error: invalid option "with-http_ssl_module"

note that every time i do this, i have reinstalled the server so its fresh.
i could just go ahead with the LEMP "Application" but id rather do things manually to learn how things work etc.

4) Finally, I think this forum could use some formatting options, things like bold, links etc

Cheers

Comments

  • this forum wont let me edit my posts either

    i have solved my issue with #3, i needed to open port 80 in the iptables:

    vi /etc/sysconfig/iptables
    -A INPUT -m state --state NEW -p tcp --dport 80 -j ACCEPT
    service iptables restart

    i would still like to know why i get the error:
    ./config: error: invalid option "with-http_ssl_module"
    when i build from source,
  • fixed another issue

    it was giving me the invalid option "with-http_ssl_module" for two reasons

    1) the openssl-devel isnt installed, it can be via
    yum install openssl-devel

    2) the ./config command was wrong and missing "--" infront of with-http_ssl_module

    so even though its now all compiled, when i run
    service nginx start
    it gives no response or error, but does nothing,
    service --status-all shows that nginx is stopped.
  • Hello,

    To answer your questions.

    1. Yes, the minimal CentOS ISO is used, but we do make modifications to it.
    2. All prices are in USD.
    3. (I'll let someone else answer this question)
    4. Thanks for the feedback!
  • @serpent

    I'm not sure why your building your own nginx (unless you *really* need something in a newer version). The version that comes with CentOS at least (what that article seems to have been based on) already has those configure options enabled.

    With the version from CentOS 7

    $ nginx -V
    nginx version: nginx/1.6.3
    built by gcc 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC)
    TLS SNI support enabled

    [skip a bunch of configure options]

    --with-http_ssl_module --with-http_spdy_module --with-http_gzip_static_module

  • @ac000

    Thanks for that info, i was compiling it because i was unsure if it had the spdy module by default.

    Right now i am having issues getting vsFTPd going on centOS

    I have followed about 10 different websites instructions for installing,changing iptables, setting up users

    but mainly it just wont even connect.

    I searched vultr's docs and theres one for setting it up with users on a mysql DB, not exactly what id want to do
  • These are the iptables rules I was using with vsftpd...

    iptables -A INPUT -s 0/0 -p tcp --dport 21 -j ACCEPT
    iptables -A INPUT -s 0/0 -p tcp --sport 1024:65535 --dport 21 -m conntrack --ctstate NEW,ESTABLISHED -j ACCEPT
  • I tried your iptables inputs, and portscan says port 21 does not respond.
    some open the port, some dont
    either way, i always get 504 gateway timeout.

    Is there any chance you or someone else can paste a list of commands, or an *.sh script that gets vsftpd working from a fresh centos6x64 deployment?

    I am half tempted to use a stock ISO from centOS.org because the modified one vultr uses seems to miss a few components that aren't necessary but most tutorials seem to use them.
  • OK, quick test, CentOS 7. There was a couple of things missing from my post.

    Install / start vsftpd (no additional configuration)
    Clear firewall rules (in this case, stop firewalld, or iptables -F)

    $ lftp 192.168.1.21
    lftp 192.168.1.21:~> ls
    drwxr-xr-x 2 0 0 4096 Jun 10 2014 pub

    Add a simple blocking firewall rule

    # iptables -A INPUT -s 0/0 -p tcp -j REJECT

    Try to connect again

    $ lftp 192.168.1.21
    lftp 192.168.1.21:~> ls
    `ls' at 0 [Connection refused]


    Load the ftp conntrack module

    # modprobe nf_conntrack_ftp

    Add firewall rules for ftp (repeat for IPv6 with ip6tables)

    # iptables -F
    # iptables -A INPUT -s 0/0 -p tcp --dport 21 -j ACCEPT
    # iptables -A INPUT -s 0/0 -p tcp --sport 1024:65535 --dport 21 -m conntrack --ctstate NEW,ESTABLISHED -j ACCEPT
    # iptables -A INPUT -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT
    # iptables -A INPUT -s 0/0 -p all -j REJECT

    Try connecting again

    $ lftp 192.168.1.21
    lftp 192.168.1.21:~> ls
    drwxr-xr-x 2 0 0 4096 Jun 10 2014 pub
    lftp 192.168.1.21:/>
Sign In or Register to comment.

Registration Required

A VULTR.com account is required to use the forum. Click here to sign in.

Quick Links