Postfix + Dovecot not forwarding emails out of console in Help

edited May 2016 in Help
Hello,

I installed postfix + dovecot in my server (Centos 6 + LEMP) following this article (i just not made ssl config):
https://www.vultr.com/docs/simple-mailserver-postfix-dovecot-sieve-centos-7

The emails sended from console works great (receiving in my outlook.com webmail):
echo "TEST" | mail -s "testmail" admin@mydomain.com && tail -f /var/log/maillog

But when I try to send a email from a external client how Outlook.com or Gmail.com (via browser) it doenst work.

My configs:

postconf -n:
alias_database = hash:/etc/aliases
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 2
html_directory = no
inet_interfaces = all
inet_protocols = all
mail_owner = postfix
mailbox_command = /usr/libexec/dovecot/deliver
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain, localhost
mydomain = mydomain.com
myhostname = mydomain.com
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.6.6/README_FILES
sample_directory = /usr/share/doc/postfix-2.6.6/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
unknown_local_recipient_reject_code = 550
virtual_alias_domains = mydomain.com
virtual_alias_maps = hash:/etc/postfix/virtual


Virtual file:
contato@mydomain.com mypersonalemail@outlook.com.br
admin@mydomain.com mypersonalemail@outlook.com.br
admin mypersonalemail@outlook.com.br
contato mypersonalemail@outlook.com.br


Anyone can help me?

Comments

  • It's hard to trouble shoot without seeing any logs or error messages. I do note the mydestination variable uses $myhostname, but that variable is not set until later. Which means $myhostname might be empty.

    Also, make sure the firewall is not blocking incoming connections from your client.

    If that doesn't work, post your postfix log that shows the e-mail client connecting.
Sign In or Register to comment.

Registration Required

A VULTR.com account is required to use the forum. Click here to sign in.

Quick Links

In this Discussion