Wordpress email notification

edited July 2016 in Features and Ideas
I'm operating a Wordpress site. I've installed the ninja forms plugin & created a couple of forms.
However the forms are not sending emails to the 'To' address in 'Email & Actions'.
Has anyone had the same problem?

Comments

  • edited July 2016
    You can generally look at /var/log/maillog and see additional information on why the delivery may be failing.

    It is possible SMTP may be restricted on your account as described here (in which case you would need to create a support ticket):
    https://www.vultr.com/faq/#outboundsmtp


  • edited February 17

    Similar issues here and had

    ```

    Feb 17 06:17:28 app-prod sendmail[19420]: unable to qualify my own domain name (app-prod) -- using short name

    Feb 17 06:17:28 app-prod sendmail[19420]: 01H6HSG0019420: from=forge, size=497, class=0, nrcpts=1, msgid=<2dc58931948d193b51388d6199091bdd@domain.com.au>, relay=forge@localhost

    Feb 17 06:17:28 app-prod sm-mta[19424]: 01H6HSR4019424: from=<forge@app-prod>, size=615, class=0, nrcpts=1, msgid=<2dc58931948d193b51388d6199091bdd@domain.com.au>, proto=ESMTP, daemon=MTA-v4, relay=localhost [127.0.0.1]

    Feb 17 06:17:28 app-prod sendmail[19420]: 01H6HSG0019420: to=user@gmail.com, ctladdr=forge (1000/1000), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30497, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (01H6HSR4019424 Message accepted for delivery)

    Feb 17 06:19:57 app-prod sm-mta[19377]: 01H5X3Zs019014: to=<user@domain.com>, ctladdr=<forge@app-prod> (1000/1000), delay=00:46:54, xdelay=00:08:44, mailer=esmtp, pri=481965, relay=vade-in1.mail.host.com. [66.33.205.212], dsn=4.0.0, stat=Deferred: Connection timed out with vade-in1.mail.host.com.

    Feb 17 06:20:01 app-prod sm-msp-queue[19454]: My unqualified host name (app-prod) unknown; sleeping for retry

    Feb 17 06:21:01 app-prod sm-msp-queue[19454]: unable to qualify my own domain name (app-prod) -- using short name

    Feb 17 06:21:47 app-prod sm-mta[19153]: 01H29R3o017425: to=<user@gmail.com>, ctladdr=<forge@app-prod> (1000/1000), delay=04:12:20, xdelay=00:21:50, mailer=esmtp, pri=840482, relay=alt4.gmail-smtp-in.l.google.com. [172.253.112.26], dsn=4.0.0, stat=Deferred: Connection timed out with alt4.gmail-smtp-in.l.google.com.

    Feb 17 06:21:47 app-prod sm-mta[19153]: 01H29R3o017425: 01H5pDZt019153: sender notify: Warning: could not send message for past 4 hours

    Feb 17 06:21:47 app-prod sm-mta[19153]: 01H5pDZt019153: to=<forge@app-prod>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=30000, dsn=2.0.0, stat=Sent

    ```

    Wonder if a port is blocked or something.

Sign In or Register to comment.