DNS resolve falied issue

In my application a lot of functions access other company's web API.
DNS resolve is often abnormal in the last month. I think that is not nameserver problem.

I using facebook API by curl in application shows "Could not resolve host", but sometimes work success, 3 times 1 time failed(resolve timeout or waiting more then 1 min).

It's can also show in command line "ping", "mtr", I took a small video to show this issue.

I tried to modify nameserver to,,,, or, all public nameservers.
I also try to disable the IPv6 nameserver, but the problem still exists.

First, I think that is not my country's network problem, because I tried to ping facebook, google, yahoo....alse have same problem.
Second, this has nothing to do with the operating system, because I have 7 Vultr VPS, I have Ubuntu, CentOS, Windows Server, there all have same problem.


  • I have solved this problem, the problem is "systemd-resolved" service always using global default setting, no matter how you modify "/etc/resolv.conf" file.

    The default nameserver is, but it unstable.
    ~# systemd-resolve --status
    You can try to show status. It's apply default setting.

    So I try to modify systemd-resolved configure
    ~# sudo service systemd-resolved restart

    It's fixed my problem.

  • Dear Friend , I am using WHM , and have this problem , but I don't find systemd to edit the config file , can you help me ?
Sign In or Register to comment.